|

RWBY Grimm Eclipse System Requirements

In this page, you will be able to find system requirements of RWBY Grimm Eclipse which you can implement on your home gaming PC to play RWBY Grimm Eclipse without any errors.

RWBY Grimm Eclipse

RWBY Grimm Eclipse System Requirements

Minimum Requirements:

  • CPU: Info
  • Processor (Intel CPU): Intel Core i5-2500K (4 * 3300) or equivalent
  • Processor (AMD CPU): AMD FX-8320 (8 * 3500) or equivalent
  • CPU SPEED: Info
  • RAM: 4 GB
  • OS: Windows 7/8/8.1/10 x64
  • Graphic Card Requirement NVIDIA: GeForce GTX 460 (1024 MB) or equivalent
  • Graphic Card Requirement AMD: Radeon HD 5570 (1024 MB)
  • SOUND CARD: DirectX 9.0c (or higher)
  • FREE DISK SPACE: 4 GB

RWBY Grimm Eclipse System Requirements

Recommended Requirements:

  • CPU: Info
  • Processor (Intel CPU): Intel Core i5-4670K (4 * 3400) or equivalent
  • Processor (AMD CPU): AMD Athlon X4 860K (4*3700) or equivalent
  • CPU SPEED: Info
  • RAM: 4 GB
  • OS: Windows 7/8/8.1/10 x64
  • Graphic Card Requirement NVIDIA: GeForce GTX 760 (2048 MB) or equivalent
  • Graphic Card Requirement AMD: Radeon R9 270X (2048 MB)
  • SOUND CARD: DirectX 9.0c (or higher)
  • FREE DISK SPACE: 4 GB
Owais Arain

Related Games System Requirement:

Tags: ,,